BPS Visual Format not displaying correctly

Home Forums BulletProof Security Pro BPS Visual Format not displaying correctly

This topic contains 4 replies, has 2 voices, and was last updated by  AITpro Admin 1 year, 7 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #31291

    Nik
    Participant

    Hello AITpro Admin,

    The BPS visual format is in disarray.  I suspect it has something to do with WPML plugin.  There was no issue on another website that had no WPML plugin installed. I installed WPML before BPS. Any suggestion on how to resolve the issue is much appreciated.

    Thanks,
    Nik

    #31292

    Nik
    Participant

    Hi AIT Pro Admin,

    My test site confirmed WPML plugin as the culprit.  I am running on the BPS Pro V 12.4.

    Nik

    #31294

    AITpro Admin
    Keymaster

    There is one known issue with WPML here that requires adding wp-admin Custom Code whitelisting htaccess code:  http://forum.ait-pro.com/forums/topic/wpml-cant-deliver-via-xmlrpc/#post-1056

    Usually when the BPS Pro plugin pages visual format is not displaying correctly it is caused by one of these problems:
    The Plugin Firewall has invalid whitelist rules and needs to be reset/cleared by doing these steps here:  http://forum.ait-pro.com/forums/topic/plugin-firewall-read-me-first-troubleshooting/  If you do not have a Proxy server use these steps:  “Fix all general Plugin Firewall issues/problems”.  If you do have a Proxy server use these steps:  “Fix all general Plugin Firewall issues/problems and Proxy server configuration mistakes”.

    One or more plugins are loading their js scripts in BPS Pro plugin pages: http://forum.ait-pro.com/forums/topic/remove-plugin-scripts-from-loading-in-other-plugin-pages/ You can try to use the BPS Pro > UI|UX Settings > Script|Style Loader Filter (SLF) In BPS Plugin Pages option > select SLF On.

    Standard BPS Pro troubleshooting steps to confirm or eliminate or isolate issues/problems:  http://forum.ait-pro.com/forums/topic/read-me-first-pro/#bps-pro-general-troubleshooting

    #31298

    Nik
    Participant

    Hi AITpro Admin,

    Thank you very much again for your timely solution.  Yes, it was the js script issue.

    Turned the SLF  ON and the issue was resolved.  It does take double time to load BPS Pro, but it’s better than trying to read a  broken visual format and working with misaligned buttons.

    I must say, BPS Pro is among the best WP security plugin.  It’s quite a bit of a learning curve, but it’s well worth it.

    Keep up the great work, AIT.

    Nik

    #31299

    AITpro Admin
    Keymaster

    Great!  Glad that worked.  Yeah, unfortunately the SLF option has to process all the Source Code in BPS plugin pages being rendered during page load in order to block other plugin’s scripts that are loading in the Source Code on BPS plugin pages.  Too bad we can’t cache that so that it would only happen once on an initial BPS plugin page load.  Nothing should ever be cached in the WordPress Dashboard area since that would cause major problems.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.