Uninstall and Reinstall BulletProof Security Pro

Home Forums BulletProof Security Pro Uninstall and Reinstall BulletProof Security Pro

Viewing 15 posts - 16 through 30 (of 35 total)
  • Author
  • #30222
    Matthew MacMillan

    I’m unable to find the Uninstall Link on the plugins page as well.

    Earlier in this thread you suggested deleting the plugin folder via FTP then re-uploading using WP admin interface.

    I tried twice and for some reason the newly added bulletproof-security folder is bulletproof-security-1 both times. That’s odd but I finally just renamed the folder (there were no other bulletproof-security folders in the plugins directory), and got the plugin working again.

    To no avail, there is still no Uninstall option anywhere.

    When I deactivate BPS on my site, a ton of admin functions stop working and in the JS console I’m getting a bunch of 403 errors. I just need to go back to my site as it was before BPS.

    AITpro Admin

    Do you have a Network|Multisite website?  If so, you need to go to your Network Admin Dashboard > Plugins page to uninstall BPS Pro.  Deactivating BPS Pro should not cause any errors.  If you are trying to troubleshoot BPS Pro then you do not want to deactivate or uninstall BPS Pro and instead want to do the BPS Pro troubleshooting steps here:  http://forum.ait-pro.com/forums/topic/read-me-first-pro/#bps-pro-general-troubleshooting

    BPS Pro should only be uploaded via FTP as a last resort if you are unable to install BPS Pro using the WordPress Upload Zip installer.  The errors you are seeing could be caused by uploading BPS Pro files using FTP.  Use the BPS Pro built-in Upload Zip installer under the BPS Pro Setup menu and reinstall the BPS Pro zip file.

    Matthew MacMillan

    I haven’t uploaded via FTP, only deleted that way. Then uploaded again via WP Admin area.

    I’m a little overwhelmed by the BPS interface, so I decided not to use it on this site. However when I turn off BPS a bunch of things are breaking. Badly. So now with no uninstall button, I’m feeling a little forced to use BPS. If I turn it off, I’m getting a bunch of permissions issues.

    Basically, I really NEED that uninstall button to come back up. But it’s not. I’m happy to give you access to my site so you can see what’s going on.

    AITpro Admin

    I have no idea what the problem is on this site, so yeah send me a WordPress Administrator login and an FTP login to this website so I can figure out what is causing these problems.  Most likely something else you have installed is breaking everything including BPS Pro.

    Matthew MacMillan

    Absolutely and Thank you! What email address?

    AITpro Admin

    Send the login info to:  info at ait-pro dot com.

    AITpro Admin

    Ok I am logged into the site and everything looks ok, but I did see some Security Log entries that indicate there is some sort of problem when I first logged in, but they are no longer occurring.  You have a plugin installed that is known to break BPS Pro:  WP Edit is known to break BPS Security Logging and causes other various problems.  http://forum.ait-pro.com/forums/topic/php-fatal-error-cannot-redeclare-bpspro_ap_check/page/5/#post-29955  So at this point when I deactivate and activate BPS Pro I am not seeing any errors and overall everything looks fine to me.  What exactly are you seeing?  Also which Browser are you using?  Chrome, Firefox, etc.

    Matthew MacMillan

    Ok so I just logged in and removed WP Edit completely. I can live without it.

    When I then deactivated BPS (which is when everything broke earlier) everything worked fine. Maybe it was just having WP Edit in the same system activated or not? Not sure.

    The browsers I was trying all this on were Chrome standard, Chrome Canary, Firefox standard, Firefox Developer. I try a lot of browsers when I find an issue.

    What else did you do? It seems everything is working. Was it only WP Edit?

    However, when BPS is turned back on, I still don’t have an uninstall tab. I know this probably doesn’t make sense and maybe I’m the only superstitious developer on the planet, but I wanted to uninstall BPS completely. Finish building the site customizations. Then actually read the BPS info so I’m not on a learning curve during a panic moment. THEN install fresh and proceed.

    So how do I do that without the uninstall button showing?

    AITpro Admin

    When I clicked the Deactivate link on the WordPress Plugins page I saw the Uninstall link.  Are you not seeing the Uninstall link for the BPS Pro plugin after you click the Deactivate link?

    Matthew MacMillan

    No, just a “Delete” link. However, I’ve just noticed something  happening again now. I had Dev Tools open, and when I deactivated BPS, I started getting a ton of errors. Then I reactivated BPS and they stopped. Even weirder, when I deactivated it again, no errors. When those errors are flowing, that’s when I was having all the problems. They are 403 GET errors from the WP installation. I’m stumped.

    Strangely this only happens when I deactivate BPS. And not EVERY time. Almost every other time. Just happened again and I copied the errors, in case you can see what’s going on:

    plugins.php?deactivate=true&plugin_status=all&paged=1&s=:56 GET http://cliff-hangerpublications.com/wp-content/plugins/captcha/bws_menu/js/general_script.js?ver=4.5.3
    plugins.php?deactivate=true&plugin_status=all&paged=1&s=:70 GET http://cliff-hangerpublications.com/wp-content/plugins/squirrly-seo/themes/default/js/sq_menu.js?ver=6130
    load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,wp-util,wp-a11y,updates&ver…:9 JQMIGRATE: Migrate is installed, version 1.4.1
    plugins.php?deactivate=true&plugin_status=all&paged=1&s=:270 GET http://cliff-hangerpublications.com/wp-content/plugins/captcha/bws_menu/js/c_o_o_k_i_e.js
    plugins.php?deactivate=true&plugin_status=all&paged=1&s=:56 GET http://cliff-hangerpublications.com/wp-content/plugins/captcha/bws_menu/js/general_script.js?ver=4.5.3 403 (Forbidden)
    plugins.php?deactivate=true&plugin_status=all&paged=1&s=:70 GET http://cliff-hangerpublications.com/wp-content/plugins/squirrly-seo/themes/default/js/sq_menu.js?ver=6130 403 (Forbidden)
    plugins.php?deactivate=true&plugin_status=all&paged=1&s=:837 GET http://cliff-hangerpublications.com/wp-content/plugins/wp-migrate-db-pro/asset/dist/js/plugin-update.min.js?ver=4.5.3
    VM3827 plugins.php?plugin_status=all&paged=1&s:270 GET http://cliff-hangerpublications.com/wp-content/plugins/captcha/bws_menu/js/c_o_o_k_i_e.js 403 (Forbidden)
    plugins.php?deactivate=true&plugin_status=all&paged=1&s=:838 GET http://cliff-hangerpublications.com/wp-content/plugins/updraftplus/includes/updraft-admin-ui.js?ver=
    plugins.php?deactivate=true&plugin_status=all&paged=1&s=:840 GET http://cliff-hangerpublications.com/wp-content/plugins/updraftplus/includes/labelauty/jquery-labelauty.js?ver=20150925
    plugins.php?deactivate=true&plugin_status=all&paged=1&s=:841 GET http://cliff-hangerpublications.com/wp-content/plugins/updraftplus/includes/select2/select2.min.js?ver=4.0.2
    plugins.php?deactivate=true&plugin_status=all&paged=1&s=:839 GET http://cliff-hangerpublications.com/wp-content/plugins/updraftplus/includes/jquery.blockUI.js?ver=2.70.0
    VM3827 plugins.php?plugin_status=all&paged=1&s:837 GET http://cliff-hangerpublications.com/wp-content/plugins/wp-migrate-db-pro/asset/dist/js/plugin-update.min.js?ver=4.5.3
    VM3827 plugins.php?plugin_status=all&paged=1&s:838 GET http://cliff-hangerpublications.com/wp-content/plugins/updraftplus/includes/updraft-admin-ui.js?ver=
    VM3827 plugins.php?plugin_status=all&paged=1&s:839 GET http://cliff-hangerpublications.com/wp-content/plugins/updraftplus/includes/jquery.blockUI.js?ver=2.70.0
    VM3827 plugins.php?plugin_status=all&paged=1&s:840 GET http://cliff-hangerpublications.com/wp-content/plugins/updraftplus/includes/labelauty/jquery-labelauty.js?ver=20150925
    VM3827 plugins.php?plugin_status=all&paged=1&s:841 GET http://cliff-hangerpublications.com/wp-content/plugins/updraftplus/includes/select2/select2.min.js?ver=4.0.2 403 (Forbidden)
    VM3830 plugins.php?plugin_status=all&paged=1&s:273 Uncaught TypeError: $.cookie is not a function(anonymous function) @ VM3830 plugins.php?plugin_status=all&paged=1&s:273i @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,wp-util,wp-a11y,updates&ver…:2fireWith @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,wp-util,wp-a11y,updates&ver…:2ready @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,wp-util,wp-a11y,updates&ver…:2K @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,wp-util,wp-a11y,updates&ver…:2
    AITpro Admin

    Yes, delete is the same thing as uninstall.  Intermittent errors/problems are usually caused by one these things:  php memory/cache/caching plugins/CDN’s/VPN’s/Proxy’s/Load Balancers/Host server problems (DNS server/DNS configuration problem, MySQL server timeout, server overloaded, etc), /Browser problems (corrupt cache, add-on, extension)/ISP (connectivity)/CloudFlare, etc.

    I will login to your site again and see if I see these errors too.  Where exactly are you seeing these errors?  Are they displayed in your WordPress Dashboard or somewhere else.  Also the errors are for every single plugin that you have installed and not just for the BPS plugin so whatever the problem is it appears to be bigger/outside of BPS Pro. ie your Browser, your computer, your website itself, your database, your host server or one of the common causes for intermittent problems listed above.

    AITpro Admin

    I logged into your site and deactivated and activated BPS Pro 12 times and did not see any errors.  So you have some kind of intermittent problem occurring only for you/your Browser.  So what you want to do is to login to your website using a different Browser and disable all Browser add-ons/extensions to eliminate that a Browser add-on/extension is causing these intermittent problems.  I used the Google Chrome Browser when I logged into your site.

    Matthew MacMillan

    The errors were in the javascript console, but it appears you weren’t getting them. Thank you very much for looking into this and helping me ferret out the problem!

    It looks like I still have a ways to go, because if this is in my browser, I’m not sure what to do. It’s happening in all my browsers, even Safari which, while being a pretty bad browser, has no plugins.

    I’ll follow the leads you’ve suggested and try to find the problem. Again, thank you very much for your help!

    AITpro Admin

    I just thought of something obvious, which is that when you are debugging things and have debuggers turned On, the debuggers themselves can trigger errors that would not normally occur.  Or insignificant issues are displayed as significant errors when debugging is used.  So since this is a known issue with debugging/debuggers then you have to do a “read between the lines” type of thing.  Example:  If you test something with a debugger turned Off and there are no problems or errors occurring and then you turn On debugging and you start seeing errors then you can safely assume that the errors are insignificant and are triggered by the debugger itself or are insignificant issues that can be ignored.

    I tried testing the Safari Browser Javascript debugger on a PC (not Mac) and deactivated and activated BPS Pro and the debugger kept freezing and crashing.  So I tried the Chrome Developer tools (pretty much the same set of debugging tools) on a PC (not Mac) and deactivated and activated BPS Pro and there were no errors displayed.

    adam tracksler

    [Topic has been merged into this relevant Topic]
    I don’t know what happened on my site, but I would like to completely reinstall BPS, When I delete the BPS folder and re-upload it, it seems to find an old quarantined file, which I Think was something corrupted in my last WP update…I’d like to nuke everything BPS and reinstall it clean.

    How can I do that?

Viewing 15 posts - 16 through 30 (of 35 total)
  • You must be logged in to reply to this topic.