JTC Anti-Spam|Anti-Hacker – Read Me First

Home Forums BulletProof Security Pro JTC Anti-Spam|Anti-Hacker – Read Me First

This topic contains 65 replies, has 15 voices, and was last updated by  Paul 1 year, 4 months ago.

Viewing 15 posts - 46 through 60 (of 66 total)
  • Author
    Posts
  • #28337

    Walter Tengler
    Participant

    Yes, great. That does it for me. Again thanks for the support.

    Walter

    #28338

    AITpro Admin
    Keymaster

    Ok great!  I got stuck on setting up Revolution Slider.  Cool setup layout, but I could not figure out how to create new Slides.  😉

    #29517

    Krzysztof
    Participant

    Hello!

    I’m  trying to put the captcha box above the content of the post:
    http://winternecie.info/2016/02/bulletproof-security-pro-czyli-o-tym-ze-wordpress-moze-byc-bezpieczny/
    I have pasted the code from the example to JTC settings and for the logged in user it of course brakes but for the not logged one it is also not perfect 😉
    But I have a Genesis theme and the style.css is a bit different compared to the examples in the first post of this thread.
    Here it is: http://wklej.org/hash/d0d2629072a/
    There is no string like .comment-form label so I don’t know where and how to put your code to have the captcha above the post window.

    #29521

    AITpro Admin
    Keymaster

    Your comment form CSS classes are shown below in your comment Form Source Code that I copied from your website.

    <p class="comment-notes">
    <span id="email-notes">Twój adres email nie zostanie opublikowany.</span> Pola, których wypełnienie jest wymagane, są oznaczone symbolem <span class="required">*</span></p>
    
    <p class="comment-form-comment">
    <label for="comment">Komentarz</label>
    <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p>
    
    <p class="comment-form-author">
    <label for="author">Podpis <span class="required">*</span></label>
    <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
    
    <p class="comment-form-email">
    <label for="email">Email <span class="required">*</span></label>
    <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
    
    <p class="comment-form-url">
    <label for="url">Witryna internetowa</label>
    <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
    
    <p class="form-submit">
    <input name="submit" type="submit" id="submit" class="submit" value="Opublikuj komentarz" />

    In your Genesis theme stylesheet the section of CSS code where you want to add your new CSS style is under this section:
    /* ## Comments
    ——————————————— */

    Example: if you add this new CSS class in your stylesheet and add a margin of 80px it would create an 80px space above Komentarz
    p.comment-form-comment {margin-top:80px;}

    #29525

    Krzysztof
    Participant

    Many thanks!
    It works! Sorto off 😉
    When I look at the form when I’m loged in it works like a charm but when someone want’s to comment without having an account I think that it added spaces in front of everry box.
    Maybe I di d something wrong?

    #29527

    AITpro Admin
    Keymaster

    JTC ONLY effects users (Administrator, Editor, Author, Contributor, Subscriber) that are logged into the site.  The logic is that if you are allowing users to post comments on your website without creating a user account and logging into your site to post comments then you obviously do not care about getting spam comments.  The only way to control comments is to require that users create a user account and login to post comments.

    Comment Form: (only applies if Comment Form CAPTCHA is enabled/checked)
    Enable|Disable JTC Anti-Spam For These Registered/Logged In User Roles:

    Users must be logged into your website for the Comment Form User Roles to work. If you do not require that users are registered and logged in to post comments on your website then these JTC Anti-Spam options will not have any effect. These options are ONLY for registered and logged in users and ONLY for your Comment Form if you are using this WordPress Discussion setting: Users must be registered and logged in to comment.

    #29529

    AITpro Admin
    Keymaster

    Maybe try adding this CSS for just the form label.

    .comment-form label[for=comment] {display:block;margin-top:80px;}
    or
    .comment-form-comment label[for=comment] {display:block;margin-top:80px;}
    

    If the form looks ok when you are logged into your site, but not ok when you are not logged in then that would mean the form is using different form code and/or CSS based on when a user is logged in or not. That sounds very unusual though so maybe it is actually a Browser cache issue. Or more likely the problem is because the page is minified. When I look at the Source Code of the page it is minified. Posts or Pages that contain Forms should NEVER be minified or cached.

    #29537

    Krzysztof
    Participant

    You have got a point with this registering thing but when I check in the option to allow comments only for registered users, under the post there is a link, that you have to log in to comment but when someone is not registered there is no option to register which is not user friendly.

    This whole Genesis thingie is starting to drive me nuts.

    I would gladly dump all the optimization plugins but no one these days makes normal themes without js. Each and every of them has tons of js and other garbage which I then have to optimize with a plugin, or even two of them which need updates which brake something or have vulnerabilities which BPS Pro has to protect. This is a insane circle.

    #29538

    AITpro Admin
    Keymaster

    It is a very standard thing with WordPress to display this under a Comment Form:  “You must be logged in to post a comment” when someone is not registered or logged in.  That should be displayed in both of those situations.  I liked your Disqus/Social Media login idea and I think we may be doing that in the future since it is very convenient for someone just to do a “connect with Disqus, facebook, etc.”  Yep, we were using a WordPress theme that someone else created, but most if not all WordPress themes are required to add all sorts of additional standard WP theme code to meet WordPress theme standards and then theme authors want to add as many other options as possible.  We created our own AITpro theme that we use on all of our sites.  It contains only the basic absolutely necessary theme code (the other 80% of WordPress standard theme code was not used) and all of the specific code customizations that we use specifically.  Total theme size is:  200KB.  😉

    #29550

    Krzysztof
    Participant

    As I understood Disqus creates a new problem – you have to somehow merge it with google analytics and it also brings the problem of privacy – nothing is for free – sometimes we don’t pay for it. With Disqus comments we share with Disqus the knowledge about our users and give them a huge data base. When you add a social plugin it also tracks users and for a nice fancy plugin we allow to track our site and our users. This gives me a head ache. Everywhere tracking, measuring, analytics – a person is no longer a person – it becomes a thing to measure just for the sake of squeezing it like a lemon and pouring all it’s dollars into the pocket of the one responsible for the squeezing. And the worst thing is that people do it to people… There – I have poured a lot of sadness into this happy place.

    That being said I thing that I will use the stock WordPress theme posted in your examples instead.
    I have managed to get Disqus running – I pasted wrongly the js to Firewall Rueles:
    /disqus-comment-system/media/js/disqus.js?ver=4.5.2 is the proper one
    and I pasted just:
    /disqus-comment-system/media/js/disqus.js
    thinking that the 4.5.2 is WordPress specific and it might change.
    And the botm botom line si – I can’t save the world. If people agree for tracking just to have a nice level of convenience I can not fight with that 🙁

    #31191

    Krzysztof
    Participant

    Hello!

    Can the captcha be integrated with stock WordPress Twenty Fifteen theme coments form?

    #31194

    AITpro Admin
    Keymaster

    @ Krzysztof – Yep, see the beginning of this forum topic and scroll down to this help section:  Comment Form CSS Styling

    #31195

    Krzysztof
    Participant

    Well I did read the forst post before posting 😉 I have pasted the code and… nothing and this is why I wrote my question.

    #31196

    AITpro Admin
    Keymaster

    @ Krzysztof – What exactly is the problem?  Are you doing everything that is required for the Comment form CAPTCHA to be displayed on your Comment form?

    Enable|Disable JTC Anti-Spam For These Forms:
    Checking a Form checkbox will display a CAPTCHA on that Form to all users. Unchecking a Form checkbox will remove the CAPTCHA on that Form for all users. The Comment Form is a special case and the CAPTCHA can be displayed based on the User Roles that you choose. See the Comment Form help section below.

    Comment Form: (only applies if Comment Form CAPTCHA is enabled/checked)
    Enable|Disable JTC Anti-Spam For These Registered/Logged In User Roles:

    Users must be logged into your website for the Comment Form User Roles to work. If you do not require that users are registered and logged in to post comments on your website then these JTC Anti-Spam options will not have any effect. These options are ONLY for registered and logged in users and ONLY for your Comment Form if you are using this WordPress Discussion setting: Users must be registered and logged in to comment.

    Checking a User Role checkbox will display a CAPTCHA to all users with that User Role on your website’s Comment Form. Unchecking a User Role checkbox will remove the CAPTCHA from displaying to users with that User Role on your website’s Comment Form.

    #31198

    Krzysztof
    Participant

    My bad – had wrong comments settings…

Viewing 15 posts - 46 through 60 (of 66 total)

You must be logged in to reply to this topic.