Dashboard Update/Upgrade Notification not displayed in WP Dashboard

Home Forums BulletProof Security Pro Dashboard Update/Upgrade Notification not displayed in WP Dashboard

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
  • #22872


    I’m using a Multi-User WordPress install on my own server, BPS Pro is network activated, and I always had trouble auto-upgrading the BPS Pro plugin. *A few times*, WP told me that a new version of BPS was available, but generally not, and I’m forced to use the zip manual install way. That’s not really hard to do, but I’d prefer to understand what’s really going on. So, yesterday, I received this mail telling me there is a new BPS version, and here is what happens today: You can install BPS Pro upgrades from within your WP Dashboard just like any other plugin update using the update now link on the WordPress Plugins page.

    Ok, I go to my WP Network Admin, updates, and don’t see any update available If you do not see an upgrade notice for the BulletProof Security Pro plugin then click the BulletProof Security Pro Manual Upgrade Check link on the WordPress Plugins page this link tries to go to http://main.site.url/wp-admin/network/admin.php?page=bulletproof-security/admin/tools/tools.php#bps-tabs-15
    and I receive the message: “you don’t have enough rights to accede to this page” (frustrating, I’m network admin!) stripping the “/network” part, I go to the BPS Pro/Pro-Tools/Plugin Update Check part of the main WP site and run the Plugin Update Check Pro-Tool, I click the “Force Plugin Update Check” button, and BPS display “Error: Unable to delete the _site_transient_update_plugins option value from your database.go to your WordPress Plugins page and refresh your Browser. nothing new here If you still do not see the update now link to install the new BulletProof Security Pro version then Refresh your Browser again on the WordPress Plugins page, if you still do not see the new BPS Pro version then clear your Browser cache and Refresh your Browser again. tried many times to no avail If you still do not see the new BPS Pro version then your Web Host or another plugin that you have installed is blocking the AITpro API Server: Using BPS Pro/Pro-Tools/Ping Website display: “ is reachable using fsockopen Port 80. Response Time: 162 milliseconds

    Please note that it is the only plugin reluctant to update itself using WP upgrade system, I never had any problem upgrading other plugins on this install

    AITpro Admin

    This forum topic covers possible problems with both BPS Pro upgrades and BPS Pro Activation Key requests

    If you are not seeing a BPS Pro update/upgrade notification on the WordPress Plugins page then try clicking the Plugins menu link 3 times (forces a plugin API update check on page reload).  You can also try refreshing your Browser on the WordPress Plugins page (two or more times) to see if the BPS Pro plugin update/notification is displayed IF something is not blocking or breaking the AITpro API server upgrade check or for one of the other reasons below.  The Plugin Update Check Pro-Tool deletes the transient DB cache.  Not sure why you are seeing that error on your site, but that may have something to do with this issue/problem.  Using the Ping Pro-Tool will only tell you that you that the AIT-pro.com IP Address is reachable and the AITpro API Server is up and not whether or not something is breaking or blocking the AITpro API server upgrade checking code.

    Screenshot of the BPS Pro plugin update/upgrade notification on the WordPress Plugins page:
    bps pro dashboard upgrade notification

    AITpro API Server, BPS Pro Dashboard Update & Dashboard Update/Upgrade Notification General Info
    The AITpro API Server IP address is:
    The AITpro API Server URL is: api.ait-pro.com
    The BPS Pro plugin/upgrade package/zip file is on the AITpro API server (all other free WordPress plugins are on the wordpress.org API Server)

    BPS Pro plugin version upgrades are on the AITpro API server.  Your website sends a POST Request to the AITpro API Server using the WordPress wp_remote_post() function to check for available BPS Pro plugin updates/upgrades.  If your website successfully sends the POST Request to the AITpro API Server and a new version of BPS Pro is available then you will see a typical/standard WordPress update/upgrade notification displayed on the WordPress Plugins page for the BPS Pro plugin:  There is a new version of BulletProof Security Pro available.

    Troubleshooting & Causes for not seeing the BPS Pro update/upgrade notification or are unable to request Activation Keys:

    The AITpro API Server: https://api.ait-pro.com at IP Address: [] is NOT reachable using fsockopen Port 80:  Make sure that you have added and saved a valid Download-Request Key in the Save Download-Request Key text box.  Try to request a BPS Pro Activation Key again using the Get Activation Key button.  After 3 failed attempts at getting an Activation Key then see possible causes below for why you are unable to get/make an Activation Key request.  Note:  If you are able to view/access the BPS Pro Setup Wizard page and it is not chopped off/blank then send an email to:  info at ait-pro dot com and state this in your email:  “I am unable to request a BPS Pro Activation Key, but I can view/access the BPS Pro Setup Wizard page and it is not chopped off/blank”.  We will email you the solution/fix for this issue.

    The current version of BPS Pro that you have installed is older than 6 months:  The AITpro API Server will not respond to a BPS Pro plugin upgrade check if the version of BPS Pro that you have installed is older than 6 months.  This is done to reduce resource usage and requests to the API Server.  The logic is that if someone has not updated/upgraded BPS Pro in over 6 months then the assumption is that the website is abandoned or not being used any longer so the upgrade Request should be ignored instead of wasting API Server resources on an abandoned website.  Use the Alternative BPS Pro Upgrade Method below to upgrade BPS Pro.

    Another plugin or theme API code is interfering with/breaking the AITpro API Server code:  If you have a paid/premium plugin or theme installed on your website that makes API connections to check for plugin or theme upgrades then deactivate that plugin or theme and refresh the WordPress Plugins page several times.  If after deactivating all paid/premium plugins or themes you are still not seeing a BPS Pro plugin update/upgrade notification on the WordPress Plugins page then deactivate all of your other plugins and refresh the WordPress Plugins page several times.

    wp-config.php setting is blocking communication to the AITpro API Server:  If you are using the WP_HTTP_BLOCK_EXTERNAL constant code in your wp-config.php file then add the ait-pro.com domain as shown below to allow communication with the AITpro API Server.

    define( 'WP_HTTP_BLOCK_EXTERNAL', true );
    define( 'WP_ACCESSIBLE_HOSTS', 'api.wordpress.org,*.ait-pro.com,*.github.com' );

    Web Host or Control Panel Setting is blocking the AITpro API Server domain, IP Address or the remote POST:  If you are blocking IP addresses in any of your web host Control Panel tools then check to make sure you are not blocking the API Server domain or IP address.  Check with your web host and ask them if they are blocking the AITpro API Server domain, IP address or WordPress Remote POST.  It is possible that your web host is blocking the wp_remote_post() function indirectly or directly.  Activation Key requests are Outgoing requests from your website to the AITpro API server.  Check that you are not blocking Outgoing requests.

    Routing Server Configuration Issue/Problem – Typically Cloud|Cloud Services or other Proxy|Load Balancer
    Other Private IP address ranges: – and –
    I’ll keep this simple in laymans terms. Basically either a Proxy or Load Balancer is routing your website/server through that Proxy or Load Balancer and instead of keeping your actual website/server IP address intact it is instead changing your website/server IP address to the internal Private 10. IP address. Front facing IP addresses need to be Public IP addresses. Example Scenario: A private corporation has internal 10. Block ip addresses, that corporation uses a router for outgoing and incoming Public traffic. That frontfacing ip address of that corporation’s router is going to have to be a Public IP address since ONLY Public IP addresses can communicate with each other. Public IP addresses are NOT allowed to communicate with Private IP addresses. That is simply NOT allowed on the Internet. So you would need to contact your host and let them know about this. You can send your web host this forum topic link and information so they will understand what the issue/problem is.  Activation Key requests are Outgoing requests from your website to the AITpro API server.  Check that you are not blocking Outgoing requests.

    Website domain is not Live yet and is in Development or Temporary Status
    Some web hosts put your website domain in temporary or development status in order to allow you to work on your site until it goes Live (DNS has propagated). You may or may not be able to request a BPS Pro Activation Key successfully until your website domain is actually Live (DNS has propagated). It all depends on how your web host creates the development/temporary website domain. If your site is not Live yet then no one else, but you can access or view your website. When your site is Live (DNS has propagated) then request a BPS Pro Activation Key.

    Website domain is in Maintenance Mode
    Some WordPress Maintenance Mode plugins, web host control panel Maintenance Modes or custom (template or other custom method) Maintenance Modes block BPS Pro Activation Key requests. You can either wait until your website domain is out of Maintenance Mode to request a BPS Pro Activation Key or temporarily take your website out of Maintenance Mode to request a BPS Pro Activation Key.

    Alternative BPS Pro Upgrade Method when the AITpro API Server update/upgrade is being blocked/broken:
    BPS Pro has a built-in Upload Zip Installer to install BPS Pro upgrade zip files. Download the bulletproof-security.zip file from the AITpro.com Secure Download Area. Under the BPS Pro Setup Main menu, click the Upload Zip Install submenu link. Click the Choose File button, navigate to where you downloaded the bulletproof-security.zip file on your computer (Note: the zip file MUST be named bulletproof-security.zip) and click the Install Zip Now button.


    Thanks for your answer. It happens I’m using an Envato theme for one of the sites. I don’t know exactly what you mean by “deactivating” a theme, all I can do is use another theme (and screw the corresponding site doing that).

    So, I set this particular site to use another theme, and deactivated the site (at least to avoid it being viewed upside-down), and launched FireFox to check the POST request you mention with FireBug, and going to extension list, the upgrade appeared.

    So it looks like there is indeed a conflict between BPS and Envato API, now, what can I do to be able to upgrade smootly without cutting down any Envato themed site, should I contact Envato or can you find a work-around for that, I’m sure I’m not the only one using those themes?

    AITpro Admin

    UPDATE:  The Envato API code has been tested and it does not interfere with the AITpro API code any longer.

    We created a function/check in BPS Pro 9.0 – Release date:  June 15, 2014 that automatically temporarily deactivates specifically the Envato WordPress Toolkit plugin (contains the Envato API code that breaks the AITpro API code) and displays an alert.  That worked fine for quite a while.  We are currently researching/looking at the Envato API connection code.


    Automatically deactivate the Envato WordPress Toolkit plugin during BPS Pro upgrades and display a one time alert.

    Workaround Solution:
    Until we can thoroughly research this issue and also not interfere with Envato API processing/update checks in general, the only workaround solution at this point is to deactivate Envato plugins or switch to non-Envato Themes in order to allow the AITpro API code to work correctly.  The time frame for when this research and development will be completed is not known at this time.  We will notify all BPS Pro folks in an automated way when this task is completed.

    Alternative Solution:
    Use the Alternative BPS Pro Upgrade Method when the AITPro API Server update/upgrade is being blocked/broken.

    Important Note:  The Envato Market API may be a completely different thing.  The Envato API that is being referred to in this forum topic is the Envato plugin or theme update checking API.  They may be one and the same.  Further research is pending to determine exactly what the newest Envato API usage/method is.


    Thank you. For the next update, I’ll try to just disable the site using the Envato theme before checking updates, if that’s all it needs, that’ll be easy enough to do.

    AITpro Admin

    Or you can always do the alternative BPS Pro upgrade method.  😉  Whichever works best for you.  This issue is obviously very irritating to us and it is a priority so it will get handled as soon as possible.  The solution will most likely require modifying both the BPS Pro API Client and Server connection code so there is no room for error on this.  😉

    AITpro Admin

    We are having an extremely difficult time figuring out anything about the Envato API.  To speed the process up of figuring out what needs to be done, please send us your theme in a zip file.  We will not actually be installing the theme and just need to look at the Envato API code to figure out what needs to be done.  Send the theme zip file to:  info at ait-pro dot com.  All theme files will be deleted after research is completed.

    AITpro Admin

    Thank you for providing your Envato API connection information.  We have tested both your Enfold theme and the Envato WordPress Toolkit plugin version 1.7.2 using your API connection information.  Both your theme and the Envato WordPress Toolkit plugin are using the same identical Envato API code.  Neither interfered with our API connection code.  So the only logical explanations I can think of for why switching your theme would have worked would be there was a transient database cache issue that was cleared up by switching your theme or this was just some sort of random thing or maybe Envato has changed something on their API server.  We have deleted the Enfold theme files and have disconnected all API connections that were using your API connection information.


    For anyone trying to upgrade BPS pro from an very old version, but can’t because the API server will not respond to an very old BPS pro plugin version upgrade check and you are trying to upload the updated version through the “Upload Zip Install submenu link”.

    You might not be able to find the menu item because it’s not there.
    In the older versions of BPS pro the link was called something different.
    In the BPS pro main menu at the bottom it was listed as “Install/Backup”.
    It took me forever to find where it was because I was looking for the wrong menu item.
    Just a little F.Y.I for others that need to do the same.


    [Topic has been merged into this relevant Topic]
    I’m receiving emails to upgrade but even forcing sites to check i get no way to upgrade from within admin or plugins.

    AITpro Admin

    @ Paul – see this Reply in this same forum topic for things you can do if your site, server or another plugin or theme that you have installed is blocking communication to the AIT-Pro.com API server:  http://forum.ait-pro.com/forums/topic/wp-mu-plugin-update/#post-22887  Sorry for the late reply.  Your post was not noticed and we do not get email notifications for BuddyPress Sticky forum topics.


    [Topic has been merged into this relevant Topic]
    I don’t think I’ve ever seen BPS Pro actually show an available upgrade on the Plugins screen. When I do a manual check, I get partial pages that never finish rendering. I don’t see the “click here” that I should see after the manual check. I’ve done the “click three times” thing to reload the plugins page but that doesn’t help.

    So this morning I downloaded the zip to do a manual upgrade. It’s just processing and processing — it’s been doing this for at least a half hour.

    I use BPS Pro on four sites. They all work about the same. I get upgrade emails but the sites don’t tell me an upgrade is available. The manual check is flaky. The zip install doesn’t work. Well, it works sometimes. It’s not working today.



    Crap. So this support site just sends robot-generated replies that don’t address my issue. Thanks for nothing. I’ll take another look at this later when I have time to debug your shoddy code.

    AITpro Admin

    @ Craig – Take a look at the possible causes for why the BPS Pro upgrade notification is not being displayed on your site(s):  https://forum.ait-pro.com/forums/topic/wp-mu-plugin-update/#post-22887


    I think the problem was related to the activation key. I regenerated that and still couldn’t see that there was an update available, but I was able to successfully install the zip. Problem is that I had 12.5 before and still have 12.5. I just downloaded the zip from your site just now in order to do the upgrade, so I know it’s the most recent (12.6.something). How can I not have the most recent version after downloading and installing it from your download site?

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.